Ir a contenido

0

SDK v2.4


2 las respuestas a este tema

#1 Fegarur

    Vago

  • Moderador Power!
  • 2,331 Mensajes:
  • Genero:Chico
  • Nivel maker: Experto
  • Especialidad: Guion

Publicado el 02 August 2008 - 09:45 AM

La versión 2.4 del SDK la podéis encontrar aquí:
SDK v2.4

Recordemos que intenta facilitar la vida a los scripters, para que no tengan que sobreescribir métodos pudiendo usar el 'alias'. Esto favorecería la compatibilidad, pero como ya hemos visto crea incompatibilidades con bastantes scripts 'normales'.

Funciona igual que el SDK 2.3, para más información mirar ese tema: SDK v2.3

#2 ramiazul

    Paladin

  • voidzonero
  • 195 Mensajes:
  • Location:Argentina, el lugar + caro del mundo
  • Interests:La verdad son muchas...
  • Genero:Chico
  • Nivel maker: Experto
  • Especialidad: Scripting

Publicado el 06 August 2008 - 06:57 PM

Mira, la verdad el SDK es una herramienta muy util para los scripters, no solo genera compatibilidades, sino que tambien limpia el codigo de las escenas...

Ahora explico el por qué la incompatibilidad:
(deben saber sobre scripts)
Spoiler

Para los que no saben nada de nada de scripts:

Spoiler

Espero que alguien me entienda con este ejemplo y perdonen si antes alguien lo habia dicho.


EDIT: Una buena noticia es que en el rpg maker vx no se va a realizar un SDK. Por que?
Porque enterbrain parece que le gusto la idea del SDK asi que el mismo maker viene mejor preparado y con una mejor estructura


Editado por ramiazul, 07 August 2008 - 03:43 PM.


#3 Fegarur

    Vago

  • Moderador Power!
  • 2,331 Mensajes:
  • Genero:Chico
  • Nivel maker: Experto
  • Especialidad: Guion

Publicado el 07 August 2008 - 06:11 AM

Sí, muchos ya sabíamos que en realidad es una gran ayuda. El problema es que la mayoría de los que usan el RPG Maker no crean sus scripts, los sacan de alguna página. Y esos scripts pueden no estar pensados ni de lejos para SDK. Es decir, que ocurrirá el problema de compatibilidad si se le ocurre instalar el SDK. Como no se va a molestar en hacerlo compatible, opta por eliminar bien el script, bien el SDK y los scripts compatibles con éste.

Total, que no creo que muchos intenten leer esto, así que lo dejo en que puede ser útil, pero finalmente no lo es tanto como estaba pensado.